[GIT Latest 2010-07-19] "sprite.cpp" Bad Encoding

Reports that are not bugs or happen because of a misconfiguration.

Moderators: SMC Team, MVP

[GIT Latest 2010-07-19] "sprite.cpp" Bad Encoding

Postby Luiji » 19 Jul 2010 20:35

sprite.cpp's file encoding is undetectable by GEdit, and probably many other text editors. It's encoding is apparently ISO-8859-1 (or something like that), as supposed to UTF-8 like the other files, which might add to the problems. I don't know how to fix the encoding, so if someone could please fix the GIT repository so that the encoding is correct, that would be great! Until then, GEdit users, just select ISO-8859-1 from the list of encodings and GEdit will properly open it.
If you've submitted a Release level and I haven't added to the level repository in over a weak, I probably missed it and you should PM me if you want it uploaded.

Custom Built IBM-Compatible (Arch Linux)
Dell Vostro (Windows 7)
Dell Inspiron 1440 (PC-BSD)
Dell Inspiron 11z (Linux Mint)
User avatar
Luiji
MVP
MVP
 
Posts: 2696
Joined: 14 Jan 2010 23:20
Location: The Mushroom Kyngdom

Re: [GIT Latest 2010-07-19] "sprite.cpp" Bad Encoding

Postby penguin » 21 Jul 2010 03:10

Tomorrow, i'll get the git and upload a fixed version for you.

Do you have KUbuntu, Ubuntu, or Windows?
my wiki page
I may disappear for a long time, but trust me, I'm still alive.
User avatar
penguin
Turtle boss
Turtle boss
 
Posts: 665
Joined: 14 Nov 2009 14:37
Location: Nebraska

Re: [GIT Latest 2010-07-19] "sprite.cpp" Bad Encoding

Postby Luiji » 21 Jul 2010 05:09

My OS makes no difference. I just need it to be converted to UTF-8.

Uploading the file here isn't my goal. It's tedious, but I can open the file if I mess with GEdit long enough. I just want it fixed in Git so no problems will arise for others, and only FluXy has access permissions for Git.
If you've submitted a Release level and I haven't added to the level repository in over a weak, I probably missed it and you should PM me if you want it uploaded.

Custom Built IBM-Compatible (Arch Linux)
Dell Vostro (Windows 7)
Dell Inspiron 1440 (PC-BSD)
Dell Inspiron 11z (Linux Mint)
User avatar
Luiji
MVP
MVP
 
Posts: 2696
Joined: 14 Jan 2010 23:20
Location: The Mushroom Kyngdom

Re: [GIT Latest 2010-07-19] "sprite.cpp" Bad Encoding

Postby BowserJr » 21 Jul 2010 09:38

Yeah, Gedit kind of sucks. I've always thought that, but now I have evidence to back me up. :)

Seems to be just a Gedit problem. Every other editor I've tried it on opens it fine (including notepad running through wine :shock: ).
"Plants need to have water poured on them because they have no hands to hold glasses of water."
User avatar
BowserJr
SMC Team
SMC Team
 
Posts: 1543
Joined: 05 Feb 2007 14:07
Location: London, UK

Re: [GIT Latest 2010-07-19] "sprite.cpp" Bad Encoding

Postby Luiji » 21 Jul 2010 18:49

I realized that when I tested it with some other editors, too. I gotta switch away from GEdit.

By the way, BowserJr, what desktop environment do you use?
If you've submitted a Release level and I haven't added to the level repository in over a weak, I probably missed it and you should PM me if you want it uploaded.

Custom Built IBM-Compatible (Arch Linux)
Dell Vostro (Windows 7)
Dell Inspiron 1440 (PC-BSD)
Dell Inspiron 11z (Linux Mint)
User avatar
Luiji
MVP
MVP
 
Posts: 2696
Joined: 14 Jan 2010 23:20
Location: The Mushroom Kyngdom

Re: [GIT Latest 2010-07-19] "sprite.cpp" Bad Encoding

Postby BowserJr » 21 Jul 2010 22:17

I'm a GNOME + Compiz fan, just because most of the software I like is GTK based, and XFCE and others are too stripped down (although I used XFCE for a long time).

My brother really likes KDE, because it does a lot more out of the box (e.g compositing), and feels more polished. It's all personal preference really.
"Plants need to have water poured on them because they have no hands to hold glasses of water."
User avatar
BowserJr
SMC Team
SMC Team
 
Posts: 1543
Joined: 05 Feb 2007 14:07
Location: London, UK

Re: [GIT Latest 2010-07-19] "sprite.cpp" Bad Encoding

Postby penguin » 22 Jul 2010 03:07

Yes, this is a gedit bug, i ran it against my visual studio, it said it was utf-8.
my wiki page
I may disappear for a long time, but trust me, I'm still alive.
User avatar
penguin
Turtle boss
Turtle boss
 
Posts: 665
Joined: 14 Nov 2009 14:37
Location: Nebraska

Re: [GIT Latest 2010-07-19] "sprite.cpp" Bad Encoding

Postby Luiji » 22 Jul 2010 18:52

It's possibly a problem with GIT that is causing the file to not be properly downloaded to the filesystem with encoding information. Sadly, I think GEdit is the only text editor in the world (at least the only text editor in the world that I know of, and I know of a lot) that has problems automatically figuring out encoding information.
If you've submitted a Release level and I haven't added to the level repository in over a weak, I probably missed it and you should PM me if you want it uploaded.

Custom Built IBM-Compatible (Arch Linux)
Dell Vostro (Windows 7)
Dell Inspiron 1440 (PC-BSD)
Dell Inspiron 11z (Linux Mint)
User avatar
Luiji
MVP
MVP
 
Posts: 2696
Joined: 14 Jan 2010 23:20
Location: The Mushroom Kyngdom


Return to Invalid

Who is online

Users browsing this forum: No registered users and 0 guests

cron